cisco交换机常用命令

1、两台主机在同一个vlan内

Switch>enable //进入特权模式

Switch#config ter//进入全局配置

Switch(config)#vlan 2 //创建vlan 2

Switch(config-vlan)#interface vlan 2 //进入vlan 2

Switch(config-if)#ip address 172.16.1.254 255.255.255.0 //为vlan 2配置地址 和子网掩码

Switch(config-if)#exit //退到上一级

Switch(config)#interface f0/1 //进入交换机FastEthernet0/1口(快速以太网口)

Switch(config-if)#switchport mode access //在端口设置接入模式

Switch(config-if)#switchport access vlan 2 //将此端口接入vlan 2

Switch(config-if)#exit

Switch(config)#interface f0/2

Switch(config-if)#switchport mode access

Switch(config-if)#switchport access vlan 2

Switch(config-if)#end 

Switch#write

实际设备中,将两台PC分别接到交换机的f0/1口和f0/2口,并配置好同一网段的IP,然后互ping,发现是可以ping 的通的,因为在同一vlan内。

2、两台主机不在同一个vlan内

同理划分两个vlan,并将两端口分别加入到两个vlan中,主机分别接两个端口,发现是ping不成功的,因为两台pc不在同一个vlan内。

 路由器

Router3:f0/0:172.16.1.2,s2/0:192.168.1.2;pc3:172.16.1.1;pc2:172.17.1.1

Router>enable

Router#config ter

Router(config)#interface f0/0

Router(config-if)#ip address 172.17.1.2 255.255.255.0

Router(config-if)#no shutdown //开启端口

Router(config)#interface s2/0 //进入串口

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#clock rate 64000 设置时钟速率

Router(config-if)#no shutdown //开启s口

同理配置Router3,并且配置两台主机IP子网掩码以及网关(网关就是直连的路由器的端口地址,必须要配)

(1)静态路由:

Router2中:Router(config)#ip route 172.16.1.0 255.255.255.0 192.168.1.2 (ip route 目标网段,子网掩码,下一条地址)

Router3中:Router(config)#ip route 172.17.1.0 255.255.255.0 192.168.1.1

(2)rip 协议

Router(config)#router rip

Router(config-rip)#network 172.17.1.0 (将网段加入)

Router(config-rip)#network 172.16.1.0

Router(config-rip)#network 192.168.1.0

(3)ospf协议

Router(config)#router ospf 100

Router(config-ospf )#network 172.17.1.0 0.0.0.255 area 100

Router(config-ospf )#network 172.16.1.0 0.0.0.255 area 100

Router(config-ospf )#network 192.168.1.0 0.0.0.255 area 100

在配置 rip ,ospf前需要删除之前用过的协议或静态路由,删除方法为no router rip或no ip route…,no router ospf

查看配置为show run.

原创文章,作者:wwh,如若转载,请注明出处:https://www.wuwenhui.cn/207.html

(0)
打赏 微信扫一扫 微信扫一扫 支付宝扫一扫 支付宝扫一扫
wwhwwh
上一篇 2012-09-27
下一篇 2012-09-27

相关推荐

  • TP-LINK路由器升级方法

    升级前请到TP-LINK官网下载对应升级软件,“首页”-“服务支持”,看到“下载中心”栏,点“更多”,选择“升级软件”查找对应软件下载。 注意: 1, 升级软件必须与当前产品型号和…

    2013-05-06
    7.6K0
  • CCProxy局域网代理共享上网

    功能简介 总体来说,CCProxy可以完成两项大的功能:代理共享上网和客户端代理权限管理。只要局域网内有一台机器能够上网,其他机器就可以通过这台机器上安装的CCProxy来代理共享…

    2013-02-01
    11.2K0

发表回复

登录后才能评论

联系我们

在线咨询:点击这里给我发消息

站长邮箱:admin@wuwenhui.cn
工作时间:周一至周五,8:30-17:30,节假日休息

微信
本站支持QQ一键注册登录,所有资源下载均在文章底部~